|
www.cadblog.pl www.cadglobe.com | Strona korzysta z plików cookies m.in. na potrzeby statystyk. Więcej >>>

stronę najlepiej oglądać z wykorzystaniem przeglądarki Chrome w rozdzielczości min. 1024 x 768 (zalecane 1280 x 1024)
|
ostatnie wydanie | w numerze | archiwum |

Blog i czasopismo o tematyce CAD, CAM, CAE,     
systemach wspomagających projektowanie... 
    
 

© Maciej Stanisławski 2009
     
ul. Jeździecka 21c lok. 43, 05-077 Warszawa     
kom.: 0602 336 579     
  maciej@cadblog.pl     
2017 rok IX
   

  

>> Strona główna | Aktualności | CAD blog | Solid Edge blog | SolidWorks blog | CadRaport Historia CAD | Sprzętowo | W numerze | ArchiwumLinki Pobierz


    


Wydanie aktualne

nr 1-2(21-22) 2017
dostępny w pdf
, wydanie flash tutaj


W przygotowaniu

nr 3-4(23-24) 2017


Wydania archiwalne

nr 1-2(19-20) 2015
dostępny w pdf
, wydanie flash tutaj

numer 1(18) 2014
dostępny w pdf
, wydanie flash tutaj


numer 1(17) 2013
dostępny w pdf
, wydanie flash tutaj


numer 1(16) 2012
dostępny
w archiwum, wydanie flash tutaj

numer 1(15) 2011
dostępny
w archiwum


numer 4(14) 2010
HD dostępny
w archiwum


numer 3(13) 2010
HD dostępny
w archiwum


numer 2(12) 2010
dostępny
w archiwum


numer 1(11) 2010 dostępny
w archiwum


numer 9(10) 2009
już dostępny
w archiwum


numer 8(9) 2009
już dostępny
w archiwum


Wydanie specjalne
numer 7(8) 2009
już dostępny
w archiwum


Numer 6(7) 2009
już dostępny
w archiwum


Numer 5(6) 2009
już dostępny
w archiwum


Numer 4(5) 2009
już dostępny
w archiwum


Numer 3(4) 2009
już dostępny
w archiwum


Numer 2(3) 2009
już dostępny
w archiwum


 

 



Środa, 10.03.2010 r.

„Maluch tony węgla babci do piwnicy nie zawiezie...”

Przepraszam za „polszczyznę” w tytule tego wpisu, ale jest to cytat, który aż prosił się o to, by wykorzystać go przy okazji opisu problemów, jakie nastąpiły w wyniku instalacji Inventora 2010 na mojej „stacji roboczej” (przyrównanej zapewne do „malucha”). Podkreślam raz jeszcze: problemów wynikających z instalacji, a dokładnie – z działań podjętych przeze mnie już po jej zakończeniu, a nie spowodowanych przez sam system 3D CAD, jakim jest rzeczony Inventor. A wracając do tytułu,  „smakowitych” cytatów już wkrótce będzie więcej...

Parafrazując słynne stwierdzenie, mogę powiedzieć, iż jaka moja stacja jest, każdy widzi: procesor pamiętający lepsze czasy, zaledwie 1 GB RAM, sporo miejsca na dwóch dyskach twardych (zwłaszcza na drugim – w końcu stacja ta pełni rolę przede wszystkim komputera do DTP, czyli składu i łamania publikacji – obecnie w zasadzie jedynie e-wydań CADblog.pl). Niewiele, ale wystarczyło do pracy z Solid Edge ST, z SolidWorks w wersjach 2009 i 2010 (beta), o Kompas 3D, tudzież opisywanym na łamach e-wydań darmowym oprogramowaniu CAD i CAE nie wspominając. Dlatego mimo pewnego czającego się gdzieś na dnie duszy niepokoju, zainstalowałem Inventora 2010.

cyt.: „Przy instalacji Inventora nie potrzeba wyłanczać Antywirusa” (zachowana pisownia oryginalna)

Istotnie, nie wyłączyłem tym razem miłego niedźwiadka stojącego na straży bezpieczeństwa moich plików systemowych i nie tylko. Instalacja przebiegała bez problemu, mimo, iż...

cyt.: „Proponuje następnym razem przeczytać dokumentację przed instalacją, co prawda obsługa i instalacja programu jest banalna, ale gdy nie przeczytamy instrukcji na pudełku to nawet domestos może zrobić nam w toalecie niezły "Meksyk".

Ano właśnie. Instrukcji nie przeczytałem, chociaż jako taka – w postaci skądinąd dobrze znanych plików pdf, była na płycie instalacyjnej. A przynajmniej tak mnie poinformowano (cytat poniżej), bo przyznam się szczerze – nie sprawdzałem (ale obiecuję poprawę... następnym razem!).

cyt.: „Zgadza się nie ma instrukcji w wersji papierowej, ale jest w PDF na płytce, oraz przy inicjalizacji instalacji w oknie głównym wyskakuje po lewej stronie Przeczytaj dokumentację - co prawda mogło by to być jak pierwsze, a nie pod przyciskiem zainstaluj program.”

Jak mogli Państwo przeczytać we wcześniejszym wpisie (z dnia 3.03.2010 r.), instalacja przebiegła prawidłowo do samego końca. Co prawda w tzw. międzyczasie należało wybrać w opcjach instalacji domyślnie jako jednostki – minimetry, a jako standard – ISO, ale powiedzmy, że w tej chwili nie jest to istotne. Faktem natomiast okazał się... brak współpracy ze strony Inventor 2010 z moją kartą graficzną (wysłużony Matrox Millenium G400 Dual Head Multidisplay), przejawiający się w niemożności uruchomienia aplikacji na dwóch monitorach. Po ograniczeniu rozmiarów wyświetlanego obrazu (Panel sterowania) do jednego monitora, problem ustąpił. Inventor 2010 pracował poprawnie, nie wieszał się. Można powiedzieć, że „maluch tym razem dał radę tonie węgla”. Ale coś mu jednak nie wyszło, bo co jakiś czas, a zdarzało się to nieraz z denerwującą częstotliwością, pojawiał się komunikat błędu: Runtime error związany z cidaemon.exe.

Uczeni w piśmie rozpisywali się już w sieci na temat tego, co może być powodem wywoływania tego błędu. Cidaemon.exe odpowiada za indeksowanie w wyszukiwarce Windows. A Inventor domyślnie zainstalował w systemie... wyszukiwarkę swoich plików (screen poniżej).

Problem można było rozwiązać w prosty sposób, wystarczyło we wspomnianej wyszukiwarce wyłączyć opcję indeksowania. Niestety, na ten pomysł wpadłem już po tym, gdy zaczęły się... kłopoty.

A zaczęły się od uruchomienia zewnętrznej aplikacji czyszczącej rejestr systemu. Pomyślałem (o zgrozo), że może poradzi sobie z eliminacją opisanego „błędu cidaemon”... Nie wolno tego robić! Nie tylko sobie nie poradziła, ale przypuszczalnie uszkodziła rejestr systemu w taki sposób, że Windows XP przestał obsługiwać funkcjonalność „drag and drop” (przeciągnij i opuść). W pierwszej chwili przekonany byłem, iż wina leży po stronie Inventor 2010 i jego nowej „Drag and Drop Interoperability” (vide screen).

A jednak nie, o czym świadczyły odpowiedzi otrzymane od VAR Autodesk (cytaty przewijające się w tym tekście pochodzą – niestety - od jednego z nich...) mówiące o tym, iż podobnego błędu nie zgłaszał nikt wcześniej. Ale to było już później, a moje kłopoty dopiero się „rozkręcały”...

Uznałem, że skoro nie da się przeciągać żadnych obiektów (plików, folderów, ikon na pulpicie, wreszcie – obiektów graficznych i tekstowych w składanym właśnie wydaniu), to należy usunąć z systemu podejrzanego o sprawienie tylu kłopotów. Czyli odinstalować Inventora 2010...

cyt.: „Odinstalowanie oprogramowania wykonujemy poprzez aplikację która ją instalowała - tutaj aplikacja z płyty DVD (winno tak robić się z wszystkimi programami – nie tylko Autodesk)”

Cóż, polemika z powyższym stwierdzeniem w zasadzie mija się z celem. Dość zauważyć, iż nie jest to prawdą, a potwierdziła to m.in. opinia eksperta z innej firmy związanej z ADSK. A ja, wtedy nie wiedząc o tym, że „winno tak robić się z wszystkimi”, a nie znajdując ikonki „uninstall” wśród narzędzi Autodesk Inventor 2010, skorzystałem z Panelu Sterowania (Dodaj/Usuń programy). I w trakcie tego procesu pojawił się komunikat z kodem 1402 i wyświetlona instrukcja „hot key” wskazująca na... błąd w rejestrze systemu. Deinstalacja nie tylko się nie powiodła, ale program wykonał „rooling back process” i „wrócił” na poprzednie miejsce. W desperacji uruchomiłem aplikację Regeidt (edytor rejestru), aby ręcznie usunąć wspomniane źródło błędu (HotKey.../Unknown/*.iam/ShellNew...). Usunąłem, ale przeciąganie i upuszczanie nie działało nadal. Inventor również nie dał się odinstalować, komunikując tym razem o „Fatal error”...

Zebrałem swoje doświadczenia w garść i rozesłałem mail opisujący problem do VAR Autodesk. Nadeszło sporo odpowiedzi, wśród nich wartościowe, mówiące wprost o tym, iż:
• lepiej wyłączyć program antywirusowy podczas instalacji, bo jego aktywność może zakłócić zmiany w rejestrze systemu dokonywane przez ADSK Inventor;
• podające odnośnik do stron ADSK z informacjami o kodzie błędu – link dla zainteresowanych tutaj: http://usa.autodesk.com/adsk/servlet/ps/item?siteID=123112&id=10297059&linkID=9240617
• wskazujące, gdzie należy szukać kluczowych zapisów w rejestrze systemu uczynionych przez Inventor 2010 – link: http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=13187758&linkID=9242018

Przyszło także kilka odpowiedzi bardziej radykalnych – mówiących np. o konieczności zachowania „czystości” systemu operacyjnego, na którym zainstalowany będzie Inventor (czyli usunięciu zbędnego oprogramowania). W zasadzie podejście słuszne, ale nie w mojej sytuacji (ze względu na 30-dniowy test pozbywanie się większości aplikacji w mojej sytuacji nie wchodzi w grę; wydaje mi się, iż w przypadku testujących system np. studentów – również takie podejście nie jest popularne; zresztą jak wspomniałem Inventor zainstalował się i działał prawidłowo, ale...).

Jak można było sobie poradzić samemu?
W mojej sytuacji najważniejsze było przywrócenie funkcjonalności „drag nad drop” do środowiska Windows XP. W końcu kiedyś muszę przecież zamknąć to e-wydanie! Tym, co zrobić z pozostałościami po Inventorze (ręcznie usuniętym z dysku C i z większości rejestru systemu), starałem się na razie nie przejmować. I sposobem okazało się... skorzystanie z narzędzia przywracania systemu (programy – akcesoria – narzędzia systemowe – przywracanie systemu). Wybrałem punkt poprzedzający moment zainstalowania Inventora... I wszystko wróciło do normy. To utwierdziło mnie w przekonaniu, że znalazłem „winnego”. Powoli zaczęły jednak napływać odpowiedzi od VAR (przypominam: Value Added Reseller) Autodesk. Z części z nich (tych przydatnych) wynikało, iż żaden użytkownik wcześniej nie sygnalizował podobnych problemów (sprawdzałem to także na zagranicznych forach – istotnie, podobne błędy raczej wiązały się z błędami samego Windows XP). Tknięty przeczuciem uruchomiłem ponownie aplikację do czyszczenia systemu – w tym zapisów w rejestrze... Inventora już nie było w systemie, a błąd pojawił się kolejny raz.

Wniosek na przyszłość: uważać podczas uruchamiania nawet firmowych aplikacji czyszczących system. Nie wydawać pochopnych opinii na temat zainstalowanego oprogramowania CAD (co piszącemu te słowa w zasadzie się udało). I zadbać o porządek w systemie, co w zaistniałych okolicznościach będzie zapewne łatwe do uzyskania (spróbuję zainstalować jeszcze raz Service Pack 3.0 do Windows XP, jeśli nie pomoże – czeka mnie przeinstalowanie systemu i formatowanie partycji systemowej)...

Gdy opisałem problemy z pracą na dwóch monitorach, otrzymałem kilka maili od Czytelników, wyrażających nie do końca pochlebne opinie na temat stabilności Inventora. Faktycznie, gdy popatrzy się np. na listę usprawnień, wprowadzonych w Service Packach chociażby do wersji 11, można poczuć się niepewnie. Jak wspomniałem jednak, daleki jestem od wydawania pochopnych (nie popartych własną oceną) osądów – zwłaszcza po tak krótkim czasie „użytkowania” rzeczonego systemu. Tym bardziej, że dopóki nie zacząłem eksperymentów, w zasadzie – działał, a przyczyna nieprawidłowości (cidaemon) była łatwa do usunięcia. Faktem jednak pozostanie, iż jak na razie żaden system CAD przewijający się przez mój komputer nie dostarczył mi takich wrażeń.

Zaistniała sytuacja stworzyła jednak doskonałą okazję do dokonania subiektywnej oceny pracy i jakości działań resellerów Autodesk w Polsce. I tutaj duże podziękowania należą się firmom (w kolejności alfabetycznej): Aplikom, AutoR KSI i PCC Polska. Z czystym sumieniem mogę polecić je wszystkim użytkownikom ADSK napotykającym na jakieś problemy. Odpowiedzi od nich otrzymane były rzeczowe, konkretne i uprzejme, a przede wszystkim – faktycznie pomocne. Chociaż nikt nie podsunął – jako „doraźnego rozwiązania” – próby przywrócenia systemu do stanu sprzed instalacji.

Natomiast jako pierwsza odpowiedzi na mail udzieliła... firma z Gliwic, w osobie cytowanego już tutaj wielokrotnie Pana Marcina. A że odpowiedź miała taką formę... cóż. Gdyby nie owa „forma”, musiałbym poświęcić więcej czasu na znalezienie tytułu dla tego wpisu...

cyt.: „Aby korzystać z funkcji Drag and Drop należy posiadać odpowiednią przeglądarkę i odpowiednie parametry stacji graficznej (maluch tony węgla babci do piwnicy nie zawiezie)...”

Pozostawię to już bez komentarza. Wnioski czytelnik może wyciągnąć sam.

Pozdrawiam
Maciej Stanisławski

 

P.S.

Jeśli ktoś z Państwa miałby ochotę skomentować ten wpis, zapraszam na Forum (dokładnie tutaj: http://www.cadblog.pl/forum/viewforum.php?f=32), albo o przesłanie maila na mój bezpośredni adres: maciej@cadblog.pl


Komentarze:

1 z 1 przez Remik78 » Czw Mar 11, 2010 9:06 am

Witam
W odniesieniu do artykułu „Maluch tony węgla babci do piwnicy nie zawiezie...” o problemach z INV. Chyba najwyższa pora zajrzeć w serce komputra i zrobić mu dość radykalny face-lifting. Muszę powiedzieć, że z INV 2010 korzystam od lipca zeszłego roku i nie odnotowuję problemów ze stabilnością systemu. Owszem były drobne problemy na samym początku ale jak to zwykle bywa z nowościami zawsze jest taki okres chorobowy. Małe dzieci też często chorują. Faktem jest, że moją stacje graficzną poważniejsze choroby ominęły bardziej z racji tego, że jest na miarę dzisiejszych czasów "uszyta" :).
Muszę też powiedzieć, że INV dość dobrze toleruje sąsiedztwo innych aplikacji CAD. Osobiście mam na tej samej stacji zainstalowany po sąsiedzku SE ST. Obie aplikacje są 64bit na "Viście Bisnes 64bit" .

A tak na sam koniec. Dochodzę do wniosku, że w dzisiejszych czasach gdzie dynamizm zmian jakie zachodzą w życiu skazują nas na ciągle niedogodności związane z pewnym niedopasowaniem. Wszystko przez zbyt wiele zmiennych do uzgodnienia by wszystko działało jak trzeba. Wniosek: Kompatybilność w 100% - coś czego nie było, niema i nie będzie.



|
powrót do strony głównej |


 

Blog monitorowany przez:


 


 

 


| reklama | redakcja | dane kontaktowe | prenumerata |
© Copyright by Maciej Stanisławski. Publikowane materiały są objęte prawem autorskim.
Przedruk materiałów w jakiejkolwiek formie tylko za wcześniejszą zgodą autora.  
webmaster@skladczasopism.home.pl. Opracowanie graficzne: skladczasopism@home.pl